به‌روزرسانی

امنیت بیشتر با قابلیت به‌روزرسانی خودکار وردپرس برای قالب‌ها و افزونه‌ها

براساس خبرهای منتشر شده، تیم توسعه‌دهنده وردپرس از نسخه ۵.۵ این سیستم مدیریت محتوا، قرار است مکانیزم به‌روزرسانی خودکار برای قالب‌ها و افزونه‌ها را فعال کند که گفته می‌شود به‌ شکل غیرمستقیم، در بالا رفتن امنیت سایت‌هایی که از وردپرس استفاده می‌کنند و رفع سریع آسیب‌پذیری‌های شناسایی و اصلاح شده، تاثیر خواهد داشت.

امنیت بیشتر با قابلیت به‌روزرسانی خودکار وردپرس برای قالب‌ها و افزونه‌ها

تیم توسعه‌دهنده وردپرس از ماه‌ها قبل در حال کار روی یک مکانیزم به‌روزرسانی خودکار برای قالب‌ها و افزونه‌های این سیستم مدیرت محتوا است. این کار عمدتا به این دلیل انجام می‌شود که اغلب صاحبان سایت‌ها پس از نصب افزونه‌ها و قالب‌ها، به‌روزرسانی آن‌ها را فراموش می‌کنند.

در حال حاضر این قابلیت برای به‌روزرسانی خودکار افزونه‌ها اجرا شده و به زودی برای قالب‌ها نیز اجرا خواهد شد.

پس از انتشار اولین به‌روزرسانی خودکار برای نسخه پایدار سیستم مدیریت محتوای وردپرس، مدیران سایت‌ها می‌توانند پیکربندی وب‌سایت را به‌گونه‌ای انجام دهند که قالب‌ها و افزونه‌ها با بررسی و فعال‌سازی یک گزینه در بخش مدیریت وب‌سایت، خود را به‌روزرسانی کنند.

همچنین برخی توسعه‌دهنگان افزونه، از همان کد برای افزونه‌ها به‌منظور پشتیبانی از سفارشی‌سازی قابلیت به‌روزرسانی خودکار وردپرس استفاده کرده و به کاربران اجازه می‌دادند قابلیت به‌روزرسانی خودکار را از طریق فشردن یک دکمه فعال کنند.

بررسی‌های محققان امنیتی طی سالیان گذشته نشان می‌دهد که بسیاری از سایت‌های وردپرس پس از اینکه هکرها آسیب‌پذیری‌هایی در افزونه‌ها و قالب‌های منقضی شده پیدا کرده‌اند، در معرض خطر قرار گرفته و هک شده‌اند.

گفته می‌شود این قابلیت که انتظار می‌رود آمار هک شدن سایت‌های وردپرس را پایین بیاورد، در نسخه ۵.۵ وردپرس قابل دسترسی خواهد بود.

 

 

توضیحات بیشتر در:

WordPress to add auto-update feature for themes and plugins

آیا با قوانین شرایط استفاده از کلیه خدمات وب‌سایت سرتفا موافق هستید؟ بله ✔ خیر ✘ مطالعه !